Encoded - INC-143 - 3D Secure – Incident details

All systems operational

INC-143 - 3D Secure

Resolved
Major outage
Started 1 day agoLasted about 3 hours

Affected

Web Services

Partial outage from 9:36 AM to 12:23 PM, Operational from 12:23 PM to 12:41 PM

Web Payment Services

Partial outage from 9:36 AM to 12:23 PM, Operational from 12:23 PM to 12:41 PM

3D Secure

Partial outage from 9:36 AM to 12:23 PM, Operational from 12:23 PM to 12:41 PM

Payment Gateways

Partial outage from 9:36 AM to 12:23 PM, Operational from 12:23 PM to 12:41 PM

Adyen

Partial outage from 9:36 AM to 12:23 PM, Operational from 12:23 PM to 12:41 PM

Cardstream

Partial outage from 9:36 AM to 12:23 PM, Operational from 12:23 PM to 12:41 PM

Updates
  • Resolved
    Resolved

    We have received confirmation from our upstream supplier that this has been resolved, they have implemented a permanent fix and have verified that the platform is operating as expected.

    The root cause of this incident was due to a routine infrastructure upgrade, this upgrade was first applied to the staging and development environments, where it completed successfully with no impact to service. However when the same upgrade was deployed to the production environment, it did not behave as expected and resulted in a disruption to transaction processing.

  • Monitoring
    Monitoring

    As of 12:01 we are seeing that 3D Secure services have been restored. We will continue to monitor and await confirmation from our upstream supplier that this has been resolved.

  • Update
    Update

    Our supplier is still working on restoring 3D Secure services with high priority and we will provide an update once more information has been made available.

  • Investigating
    Investigating

    Our upstream 3D Secure provider has notified us of an incident between 04:00am - 04:20 which has now been resolved.

    We have been notified by our upstream supplier that a seperate issue is now intermittently affecting transaction processing and we are seeing intermittent issues with 3DS2 authentication, which is resulting in a high number of 'Authentication attempted' responses being received by our upstream supplier.

    Encoded will still attempt to process 3DS2 transactions that have received an 'Authentication attempted' response, however you may see an increase in declined rates whilst this issue is ongoing, as card issuers may be less likely to authorise a transaction that has not had a successful 3DS2 authentication performed. If you have implemented your own integrations with our APIs, please ensure that you continue to send transaction challenge responses to the API that receive a "transStatus" of "A", as this will ensure that the transaction is still attempted, maximising the chance of authorisation of the transaction.

    Our upstream 3DS supplier is currently investigate what is causing the increase and this page will be updated with further information once available.